Cannot display images on jupyterlab

Dear Jupyter users,

I am using a kind of python interface, py4vasp, and this displays some images from the data, which is output from VASP, the software I use.
Although jupyterlab can display 2D images like line charts, when I was trying to display 3D structure of molecules, the error was issued as follows:

Error displaying widget: model not found

I tried uninstall and install jupyterlab again to fix this problem, but it didn’t work.
My extension list of jupyter lab is as follows;
:~/vasp.6.4.0/tutorial/bulk/e05_cd-Si-relaxation$ jupyter labextension list
JupyterLab v3.5.3
jupyterlab-plotly v5.9.0 enabled OK
nglview-js-widgets v3.0.1 enabled OK
@jupyter-widgets/jupyterlab-manager v3.0.0 enabled OK (python, jupyterlab_widgets)
@pyviz/jupyterlab_pyviz v2.0.2 enabled OK (python, pyviz_comms)

I think this is the problem concering with jupyterlab extensions. Could anyone show me how to fix this problem?


You aren’t showing us the result of %conda list here or how you installed things. Because Anaconda/conda is your package manager, or it to work you need conda to have installed all the things listed here. Preferably close Jupyter and go in the environment running Jupyter and run the following on the command line (based on here):

conda install -c conda-forge vasppy

Only after that is successful, should you try to open Jupyter and try your code again.

That above is ideal. If that doesn’t work, try next in the notebook where you want to run it, the following in a new cell:

%conda install -c conda-forge vasppy

Hopefully it runs successfully, and then you can restart the kernel and try your code.
I am purposefully suggesting you avoid trying the magic install command route first (the one I suggested only as a backup) because I know with ipywidgets and some more tricky display things that installing from within the notebook doesn’t always complete as well as it should, or maybe I’ve just been unlucky or didn’t stop and restart everything well enough. However, based on what I’ve read stated by others with these more complex dependencies that could be involved here, the use of the magic install from within the notebook isn’t always as thorough as needed on its own.

1 Like

Thank you for your reply.

Preferably close Jupyter and go in the environment running Jupyter and run the following on the >command line (based on here):

conda install -c conda-forge vasppy

The command above worked and the problem was solved.
Please let me know if there is any information that I should share for the reference.


Glad to hear that solved things.

Bring up about the result of %conda list was more thinking ahead to your next post along these lines, of if the suggestion didn’t solve things.