Browser does not work in JupyerLab

FIle and directories disappear in File Broser of JupyterLab
Esto está instalado
jupyter 1.0.0
jupyter-client 8.2.0
jupyter-console 6.6.3
jupyter-core 5.3.1
jupyter-events 0.6.3
jupyter-lsp 2.2.0
jupyter-server 2.6.0
jupyter-server-terminals 0.4.4
jupyterlab 4.0.2
jupyterlab-horizon-theme 3.1.1
jupyterlab-pygments 0.2.2
jupyterlab-server 2.23.0
jupyterlab-widgets 3.0.7
nbclassic 1.0.0
nbclient 0.8.0
nbconvert 7.5.0
nbformat 5.9.0

I see that OneDrive is involved. From what I’ve see, OneDrive puts things in places that users don’t realize, see this thread. It may help you start to sort out what is going on. See also here.

Thanks for your answer, but this is not the problem, because when the mouse is on the browser, mark files, but its name is not show it

I see. That is a weird glitch.

Was it working before and something changed?

Have you tried using Jupyter in a different browser?

Does it happen for all folders though?

What if you switch to light mode?

fomightez, thanks for your answer. Yes I have used others browser, FireFox, Brave, Opera, no changes, the same problem. I have switch to light mode, no changes. But, I am remembering tht this issue was after a windows update, before this, jupiterLab worked fine. Yesterday I uninstall all Jupiter and Python too, and I installed all from zero, but the problem is the same, I don’t know what I can do

Does it happen if you use JupyterLab served via a remote computer, too? You can go here and click ‘Launch Binder’ there. A session should start up eventually. Try the file browser panel in that session there. You should be able to drag local files from your system onto the remote system to test.

How did you install? If you haven’t tried the Anaconda Distribution yet, maybe try that and see if it helps? It may be isolated enough form whatever is underlying this issue on your system to help.

fomightez thanks for your answer. Well I use Jupyterlab from 2021. I have installed python jupiterlab and everthing with pip and until 3 day ago, always was fine. Well, I don’t know what is happening, really

Did you try from the remote system too? Instead of using your local installation.

This is a problem for me as well. I cannot browse to another directory.

Did you mean to post that in this ‘Access the parent folder with JupyterLab’ thread?

You are posting under a case where the files were there but didn’t give an indication that they were there unless you moused over them.
In your case, you see files and a directory listed. Not the same issue.

Can you browser into the data directory listed there? If you can, then you indeed can browser into another directory.

1 Like

You are absolutely correct. I can browse to the ./Data directory. I should’ve been more careful in posting. I figured it was related. Newbie error. Thanks for this link. This is exactly what I needed to find.