Using s3Contents with TLJH

Hi,

Is s3 contents (GitHub - danielfrg/s3contents: A S3 backed ContentsManager implementation for Jupyter) meant to work with TLJH?

I’ve placed a config file in jupyterhub_config.d but TLJH still loads the filesystem from my server.

Thanks

In general JupyterHub doesn’t care about your ContentsManager. You need to configure it in your user directory. Have you tried getting it to work using JupyterLab/notebook without JupyterHub first?

It works fine with standalone JupyterLab.

But not with TLJH. I am following the guide here: Custom configuration snippets — The Littlest JupyterHub v0.1 documentation

I know the file is being read, as the file threw a few dependency errors when I first deployed it.

The JupyterHub and JupyterLab configurations are separate. JupyterHub is configured centrally, but JupyterLab/notebook are mostly customised in the user’s own environment. What happens if you put the JupyterLab/notebook config in your user directory?

Ah, understood.

That worked.

Is there a way to specify a default config file for the user environment?

Not in JupyterHub, but you can add a file to your system’s /etc/skel that is used to initialise the home directory when a new user is added: Share data with your users — The Littlest JupyterHub v0.1 documentation