Notebook 7 issues -- json schema? NBclassic?

(macOS 13.5 with homebrew Python 3.11.4)

I’ve just (been) upgraded to notebook 7. I guess I’ve been seeing the warnings and so knew it was coming, but (like I suspect most people) I’ve ignored them! And now, when trying to launch Jupyter, I am seeing error messages on the console.

[W 2023-07-25 10:00:48.290 JupyterNotebookApp] Missing or misshapen translation settings schema:
    HTTP 404: Not Found (Schema not found: /opt/homebrew/Cellar/python@3.11/3.11.4_1/Frameworks/Python.framework/Versions/3.11/share/jupyter/lab/schemas/@jupyterlab/translation-extension/plugin.json)
[W 2023-07-25 10:00:48.290 JupyterNotebookApp] Settings directory does not exist at /opt/homebrew/Cellar/python@3.11/3.11.4_1/Frameworks/Python.framework/Versions/3.11/share/jupyter/lab/schemas
[W 2023-07-25 10:00:48.331 JupyterNotebookApp] Missing or misshapen translation settings schema:
    HTTP 404: Not Found (Schema not found: /opt/homebrew/Cellar/python@3.11/3.11.4_1/Frameworks/Python.framework/Versions/3.11/share/jupyter/lab/schemas/@jupyterlab/translation-extension/plugin.json)
[W 2023-07-25 10:00:48.331 ServerApp] 404 GET /lab/api/settings/@jupyter-notebook/application-extension:shell?1690275648326 (::1): Schema not found: /opt/homebrew/Cellar/python@3.11/3.11.4_1/Frameworks/Python.framework/Versions/3.11/share/jupyter/lab/schemas/@jupyter-notebook/application-extension/shell.json
[W 2023-07-25 10:00:48.331 JupyterNotebookApp] wrote error: 'Schema not found: /opt/homebrew/Cellar/python@3.11/3.11.4_1/Frameworks/Python.framework/Versions/3.11/share/jupyter/lab/schemas/@jupyter-notebook/application-extension/shell.json'
    Traceback (most recent call last):
      File "/opt/homebrew/lib/python3.11/site-packages/tornado/", line 1784, in _execute
        result = method(*self.path_args, **self.path_kwargs)
      File "/opt/homebrew/lib/python3.11/site-packages/tornado/", line 3290, in wrapper
        return method(self, *args, **kwargs)
      File "/opt/homebrew/lib/python3.11/site-packages/jupyterlab_server/", line 48, in get
        result, warnings = get_settings(
      File "/opt/homebrew/lib/python3.11/site-packages/jupyterlab_server/", line 370, in get_settings
        schema, version = _get_schema(schemas_dir, schema_name, overrides, labextensions_path)
      File "/opt/homebrew/lib/python3.11/site-packages/jupyterlab_server/", line 47, in _get_schema
        raise web.HTTPError(404, notfound_error % path)
    tornado.web.HTTPError: HTTP 404: Not Found (Schema not found: /opt/homebrew/Cellar/python@3.11/3.11.4_1/Frameworks/Python.framework/Versions/3.11/share/jupyter/lab/schemas/@jupyter-notebook/application-extension/shell.json)
[W 2023-07-25 10:00:48.332 JupyterNotebookApp] 404 GET /lab/api/settings/@jupyter-notebook/application-extension:shell?1690275648326 (ed64125dd12e4ddb8ddd6b3cd75187af@::1) 2.79ms referer=http://localhost:8888/tree

In the browser, I just see the Jupyter logo in the upper left.

I’ve actually got Jupyter running on two machines; on the other machine I had the same issue but played around in various ways (attempting to launch jupyter lab instead of notebook, and possibly playing with files in ~/.jupyter and ~/Library/Jupyter in ways that I did not record…). On that machine, I still get the error message but the notebook does seem to launch.

Also, possibly related: on the other machine, jupyter nbclassic gives a 500 error; on this machine, it seems to work fine.

Also, I’ve run Jupyter in a venv and everything seems to work ok… (which implies that it’s a config problem of some sort, which is not unlikely since I’ve been running it and ipython in various guises for over a decade.

Any ideas? Do I just have to remove the entire set of config files and start over? (Is there a list of relevant locations for macOS anywhere?)


Thanks @defjaf for reporting :+1:

It looks like this might be the same issue as Missing or misshapen translation settings schema · Issue #6974 · jupyter/notebook · GitHub ?

1 Like

It certainly seems related to that.

There are some other symptoms which might or might not be related:

  • the “Open in…” (used to be called “Interface”, I think?) menu does not appear
  • In the file list window which opens from jupyter notebook, the “File” menu ends with “Save and export notebook as…” – it is missing “Trust notebook”, “Close and Shut Down Notebook”, “Log out” and “Shut Down”.

These can be ameliorated by the environment variables
JUPYTER_PATH=/opt/homebrew/share/jupyter JUPYTER_CONFIG_PATH=/opt/homebrew/etc/jupyter although there are still console messages about templates.

(Those environment variables also seem to fix my related nbclassic issue.)

Also possibly relevant:

Python 3.11 is installed by homebrew, but all packages, including jupyter, notebook, etc. are installed with pip.

Even I’m getting the same error but on my windows. What should I do?