No connect to local ftp server

Bug description

Hello colleagues! I have a problem, I have not encountered it before. On the old version of jhub, ftp connection works, on the new one it doesn’t. At the same time, the settings for k8s and jhub were made approximately the same. DNS at the same time works fine, it comes to web services, but not to ftp. Tell me where to look and is it related to ndots 1? Tried to enter both external IP and local and DNS name.

Expected behaviour

Must connect to local FTP

Actual behaviour

Can’t connect to ftp

How to reproduce

  1. Open Filezilla
  2. Connect to ftp server
  3. No connect - error

Your personal set up

Installing JupyterHub — Zero to JupyterHub with Kubernetes documentation - Installed from here, version 1.2.0 (1.5.0)

  • OS:
    ubuntu 20.04
  • Version(s):
    jupyterhub --version 1.2.0 (1.5.0), python --version 3

Screenshot from 2022-03-14 17-04-42
Screenshot from 2022-03-14 17-03-57

My old version jhub:
Screenshot from 2022-03-14 17-36-07

I apologize for not supporting the template, I see no reason to throw off the rest of the configuration, jhub itself works fine, except for the FTP connection

What’s changed between your two deployments? Is it just the Z2jh version that’s changed? Are you using different versions of K8S, or a different K8s provider?

You might check the network policy configuration. It should allow by default, but it’s possible it has been blocked in config.

Hello everyone again! Thank you for your responses. Thanks for helping me resolve this issue. I use my local server for jhub. A multi-master setup was made for the new k8s. Previously there was one master. And also updated the version of jhub to the latest. We recently switched to freeipa and had to configure both dns and prescribe ndots1 to solve the problem with dns inside k8s. On the old version, ndots1 was also registered. Configs are configured idenetichny. I have no doubt that the problem is most likely possible in k8s, but where can I see it and what needs to be configured? Network Policies did not help, set both true and false. No difference.

GitHub - tlkh/onprem-gpu-cluster-setup: On-prem GPU Cluster Setup - The assembly that I used on the old k8s.

It’s possible the problems have occurred as a result of this change to your K8s architecture, or perhaps to your underlying hosts. Do you have a way to verify K8s is correctly setup? Can you test the Z2JH upgrade on your old cluster, to reduce the number of components that need to be investigated?

figured out what the problem is. the last config was configured by my colleague, he is no longer there and I did not pay attention to egress. I commented it and it worked. And what is strange, on the old version did not block anything. On this occasion, and did not begin to look for this problem.