Mysterious jupyterlab bug causing displayed text to be distorted in both notebooks and editor


If this bug exists elsewhere, I haven’t been able to come up with a meaningful description of it to track down others’ questions, so apologies if this is a solved issue. I hope the attached GIF renders properly, otherwise I can try to share still images.

In addition to being unable to locate solutions, this has been mostly just a nuisance for a while so that I’ve tried just working around it, but at this point I’d like to stop wasting time with workarounds.

Randomly while editing something in Jupyter Lab, whether it’s a notebook, a python file, a markdown file, etc…, the text will randomly have spaces inserted between words/characters to the point of distorting the entire line. Once I click on the cell (in a notebook) or highlight the text (in a text file of any kind), the distortion disappears. There is no record of it in saved files, so it’s an inherently difficult to debug and document phenomenon. It’s occurred through multiple different environments and installations of Jupyter Lab with and w/o extensions. I am hosting Jupyter Lab on a remote Ubuntu server, which Im port forwarding to my local windows desktop, and viewing Jupyter Lab through either an opera or chrome browser. The problem remains.

Any insight would be very helpful, thanks.

1 Like

Thank for posting this! It looks very interesting… What version of JupyterLab do you use? Does it happen with a specific notebook/code, or does it happen everywhere randomly?

Can you go through the troubleshooting instructions for jupyterlab at Reporting an issue — JupyterLab 3.1.0 documentation ? In particular, my first thought is that it might be caused by a browser extension.