Latex equations not rendered in Jupyterlab

I am using jupyter lab on my MacOS with following details;

jupyter core     : 4.6.3
jupyter-notebook : 6.1.4
qtconsole        : 4.7.7
ipython          : 7.18.1
ipykernel        : 5.3.4
jupyter client   : 6.1.7
jupyter lab      : 2.2.8
nbconvert        : 6.0.7
ipywidgets       : 7.5.1
nbformat         : 5.0.7
traitlets        : 5.0.4

As well as python version : with the browser, safari version 14.0. But while using markdown mode, I tried to with mathematical equations; it is not rendering properly, please see screenshot.

enter image description here

I am a new user of jupyterlab and was wondering, do I need to install Mathjax separately. Because when I used to use vanilla jupyter notebook, I never encountered this issue. Help is appreciated.

Mathjax should be automatically used. Do you see any javascript errors in your browser console?

Appreciate your response. As suggested, I did look at the Javascript console, and there seems to be some error messages, please see screenshot;

I will admit honestly, I am not very sure what that message means. If possible, can you kindly help me here? Thanks

It looks like there are some problems with some custom extensions you may have installed.

If I were you, I’d follow the steps in the troubleshooting guide to try to narrow down where the problem is:

Appreciate your response. Sure, I will look into it.

Hi i have the very same issue with jupyterlab 3, so i wonder if you found a solution or figured out which extension is problematic.

I’m having a similar problem. When checking my browser console I see I’m getting a ReferenceError “MathJax is not defined”. Any idea how could this be solved?

Same issue, markdown and LATEX not rendering at all in a JupyterLab notebook running in an up to date safari browser on OSX Monterey, The same code WILL run in a Jupyter notebook, rendering perfectly! So the issue is with JupyterLab…

Note: both Jupyter and JupyterLab were launched from Anaconda Navigator. There were issues with installing the latest version of the navigator too.

The same here. I am running JupyterLab with Chrome and macOS Big Sur Version 11.4. It is a tricky error. When I “reload” the page in Chrome, sometimes the Latex is rendered correctly. It looks like a fault inthe javascript created by JupyterLab.

I also have the same issue. I’ve been using the standard JupyterLab download from the anaconda distribution, and have not been able to get any LaTeX text to render in markdown cells. Nor, for that fact have I been able to get png’s in markdown cells to render either.

I had the same issue. I fixed it by enabling extensions (click the puzzle icon, then enable). I didn’t have to add any new extensions, just enabling the two that were installed already was enough.