Kernel issue on Azure App service

I’m completely new to hosting jupyter, and set it up on a local Linux server for one of our developers. It was all good and running, but I’m now trying to migrate the solution to an Azure App Service. It was up and running, but for some reason it has now stopped working, and I cannot figure out why.

What I’m experiencing is that the kernel simply wont start and just throws an error: “Error Not found.” This happens for "Python3 (ipykernel), Julia 1.10.2 and R. All of them throws the same error, when trying to start them from the launcher. Seemingly, the container starts perfectly, running jupyterlab Version 4.1.5, pulled image from Quay.

Trying to start the Terminal from the Launcer throws “Launcher Error Not Found”.

I can’t find anything in any logs, that points me to what actually is the problem and why it suddenly started failing.

I’ve mapped a storage account to the /home/jovyan folder, and the files can be accessed just fine, and they show up in the left sidebar of the running instance. They can be opened but the kernels doesn’t seem to be able to run.

I’m completely baffeled and was hoping someone with more experience with jupyter could have some insight that might point me in the right direction.

Drilling a little further into this issue, it seems that it works with the: URL, but when we go through the application gateway, everything breaks down.

It’s seemingly the websocket fuctionality that fails. However, I cannot see why or how to solve it. The API: - answers with: “Can “Upgrade” only to “WebSocket”.”

So it seems it’s able to give a coherent response.

2024-04-02T13:45:07.2484339Z [W 2024-04-02 13:45:07.248 ServerApp] Blocking Cross Origin API request for /api/events/subscribe. Origin:, Host:

I’ve tried to set the CORS setting for the application i Azure Portal, however, this does not seem to be respected by the instance.