Juypter Notebook Won't Open After Python Update

Hi, I just updated to the latest version of python (3.10.9) and now my juypter notebook is no longer opening. I get the following error in my terminal:

Traceback (most recent call last):
  File "/opt/anaconda3/bin/jupyter-notebook", line 7, in <module>
    from notebook.notebookapp import main
  File "/opt/anaconda3/lib/python3.7/site-packages/notebook/notebookapp.py", line 47, in <module>
    from zmq.eventloop import ioloop
  File "/opt/anaconda3/lib/python3.7/site-packages/zmq/__init__.py", line 42, in <module>
  File "/opt/anaconda3/lib/python3.7/site-packages/zmq/__init__.py", line 9, in _load_libzmq
    import sys, ctypes, platform, os
  File "/opt/anaconda3/lib/python3.7/ctypes/__init__.py", line 7, in <module>
    from _ctypes import Union, Structure, Array
ImportError: dlopen(/opt/anaconda3/lib/python3.7/lib-dynload/_ctypes.cpython-37m-darwin.so, 2): Library not loaded: @rpath/libffi.6.dylib
  Referenced from: /opt/anaconda3/lib/python3.7/lib-dynload/_ctypes.cpython-37m-darwin.so
  Reason: image not found
Saving session...
...copying shared history...
...saving history...truncating history files...
[Process completed]

I have tried uninstalling and reinstalling anaconda navigator but that doesn’t work. I also tried uninstalling and reinstalling pyzmq, but the same error still persists.

I wonder if it is something to do with it trying to find a python3.7 file when I have now updated? Does anyone know how I can update that or any other tips about how to fix this error?

Hi @JoeRoot, Did you resolve this in the end?