Hi guys, I can't run jupyter anymore. Can you help me?

Hello to everyone! I can’t run jupyter anymore, could someone help me with this?
I tried some solutions but nothing worked. Under here there is the code my terminal keep showing.
Thank you in advance for reading (:

(base) (prova-env) tamburo:Desktop palmpalm$ jupyter notebook
Traceback (most recent call last):
  File "/Users/palmpalm/Desktop/prova-env/bin/jupyter-notebook", line 5, in <module>
from notebook.notebookapp import main
  File "/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/notebook/notebookapp.py", line 49, in <module>
from zmq.eventloop import ioloop
  File "/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/__init__.py", line 62, in <module>
from zmq import backend
  File "/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/__init__.py", line 32, in <module>
raise original_error from None
  File "/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/__init__.py", line 27, in <module>
_ns = select_backend(first)
  File "/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/select.py", line 32, in select_backend
mod = import_module(name)
  File "/usr/local/Cellar/python/3.7.5/Frameworks/Python.framework/Versions/3.7/lib/python3.7/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
  File "/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/cython/__init__.py", line 6, in <module>
from . import (
ImportError: dlopen(/Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/cython/constants.cpython-37m-darwin.so, 2): Symbol not found: ____chkstk_darwin
  Referenced from: /Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/cython/../../.dylibs/libsodium.23.dylib (which was built for Mac OS X 10.15)
  Expected in: /usr/lib/libSystem.B.dylib
 in /Users/palmpalm/Desktop/prova-env/lib/python3.7/site-packages/zmq/backend/cython/../../.dylibs/libsodium.23.dylib
(base) (prova-env) tamburo:Desktop palmpalm$

What version of pyzmq do you have installed? Looks like maybe you need to upgrade that package as it’s missing some low-level compiled attribute. If reinstalling that dependency doesn’t work I’d search issues on that project’s github and see if someone has a solution or report the issue directly there if not.