JupyterLab 4: getpass() not reading capital 'L' as that is a keyboard shortcut

Hi all,
I have found a very annoying behavioral bug when using the getpass() function in JupyterLab 4. The problem is that while a user is prompted for password entry, the “show line numbers” shortcut Shift+L has precedence over actual password entry. This is extremely annoying to users, in particular when working in corporate environments where very long passwords are required.

Expected behavior is that a user, when prompted for password input with getpass, pressing Shift+L should want an ‘L’ entry in the password field as first priority.

As a proposal, change behavior so that any Shift+something command is disabled once there is a pending getpass() call somewhere in the same notebook. This could possibly require further visualizations.

Current workaround is to instead use CAPS LOCK for entry, but IMHO that is not a good match as the enforcement of more complicated passwords grow and password typing is more or less done by ‘muscle memory’ rather than slow spelling-out of each letter.

New to the forum, so how could this get further attention?

It was all user input, and strangely enough I put in a ticket about this yesterday. It started in JupyterLab 4.0.5 so any version before that will work until they can fix it.