JupyterLab 1.0 Release Candidate published

FYI, we just published the JupyterLab 1.0 release candidate to pypi (1.0.0rc0). Please test this, and if you have an extension, we encourage you to try updating your extension to work with it.

You can install it with: pip install --pre jupyterlab. You can check the JupyterLab version from the Help > About menu item.

The current plan is to publish JupyterLab 1.0 in about a week. We will be updating documentation and the changelog and fixing a few small UX issues in the meantime.

You can see the list of issues and PRs closed in the 1.0 milestone at https://github.com/jupyterlab/jupyterlab/milestone/2?closed=1

12 Likes

This is exciting news, congratulations!!

Do you know if there is a plan to update https://github.com/jupyterlab/jupyterlab-demo and where I could follow along? It is one of the high traffic repos on mybinder.org (and might get even more traffic when 1.0 is announced!!) which makes me interested to know ahead of time what is happening :slight_smile:

1 Like

Wow!!! I really find JupyterLab to be one of these high impact projects, great work so far everybody!

I’ll try helping out with testing and reporting!

2 Likes

The plan is to update our extensions over the next week (and encourage everyone else to do so as well). Once extensions are updated, we can update the demo binder as well.

As always, help is welcome!

1 Like

As a clarification, please test jupyterlab itself without any extensions installed. We’ll be updating extensions through the week, but I don’t think any will work right now with JupyterLab 1.0rc0.

2 Likes

Any many thanks to everyone who has worked so hard for get us to this point!

1 Like

the pip install downgrades tornado to < 6 ? Is that on purpose?

Installing collected packages: tornado, jupyterlab-server, jupyterlab
  Found existing installation: tornado 6.0.3
    Uninstalling tornado-6.0.3:
      Successfully uninstalled tornado-6.0.3
  Found existing installation: jupyterlab-server 0.2.0
    Uninstalling jupyterlab-server-0.2.0:
      Successfully uninstalled jupyterlab-server-0.2.0
  Found existing installation: jupyterlab 0.35.6
    Uninstalling jupyterlab-0.35.6:
      Successfully uninstalled jupyterlab-0.35.6
Successfully installed jupyterlab-1.0.0rc0 jupyterlab-server-1.0.0rc0 tornado-5.1.1

Yes, but that has thankfully been taken care of now. Tornado 6 had a bug that we were hitting quite frequently, and the newly published tornado 6.0.3 has just fixed it.

See https://github.com/jupyterlab/jupyterlab/pull/6694 for the commit which removes this pin, and has links to relevant info. jlab 1.0 will just blacklist the few versions of tornado 6 that won’t work.

1 Like