JupyterHub 4.0.1 always redirecting to /tree instead of /lab on login despite setting Spawner.default_url

Hello everybody,
yesterday I updated a test installation of JupyterHub to the latest version of all components (JupyterHub 4.0.1, JupyterLab 4.0.3 and Notebook 7.0.0), but now I have troubles: when I login as the administrator user the hub starts with /tree instead of /lab despite setting the c.Spawner.default_url to /lab.
Is anybody experiencing a similar behaviour? Is thete a way to fix that?

1 Like

I temporarily solved the issue by downgrading to notebook < 7.0.0

1 Like

A me-too on this issue. Downgrading to notebook=6.5.4 fixed this for me as well! Anybody know of a github issue tracking this problem?

Thanks for the workaround - banging my head for a while on this one.

There is something similar at jupyterhub 4.0.1 doesn’t load jupyterlab automatically if Spawner.default_url is “/lab” #4510 . It looks like not quite the same presentation of symptoms, but maybe relevant info for root cause.

1 Like

I temporarily solved the issue by clicking View > Open JupyterLab on the menu of notebook

FYI a new 7.0.2 release of notebook is available and should fix the redirect issue: Release v7.0.2 · jupyter/notebook · GitHub