Jupyter Notebook 7 in Chrome on MacOS 13.4

Hi All,

I rebuilt my conda environment tonight and noticed all of a sudden that the jupyter notebook 7 home page is no longer displaying in Chrome after executing jupyter notebook at the command line. I’ve verified that it is still working as expected in Safari. In Chrome I’m staring at a blank webpage. Not sure what has changed recently as it was working just fine as of late in Chrome. I doubt it is a Chrome extension issue but I did toggle one extension that I thought might interfere. No change.

On the command line, I am seeing this message. Not sure it’s relevant.

0.00s - Debugger warning: It seems that frozen modules are being used, which may
0.00s - make the debugger miss breakpoints. Please pass -Xfrozen_modules=off
0.00s - to python to disable frozen modules.
0.00s - Note: Debugging will proceed. Set PYDEVD_DISABLE_FILE_VALIDATION=1 to disable this validation.

In the Javascript console, I’m seeing

bundle.js:1 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading 'call')
    at v (bundle.js:1:516)
    at 28182 (2401.bundle.js:1:21422)
    at v (bundle.js:1:516)
    at 15862 (2401.bundle.js:1:1429)
    at v (bundle.js:1:516)
    at 72401 (2401.bundle.js:1:3126)
    at v (bundle.js:1:516)
    at bundle.js:1:17130
    at v.m.<computed> (bundle.js:1:48511)
    at v (bundle.js:1:516)

Any suggestions on how to rectify this? It’s not a deal breaker to have to use Safari for the moment, but would be more convenient to be able to use Chrome.

Thanks @diehl for reporting.

At first glance it sounds similar to the following issues:

Did this happen when updating notebook from an existing environment? Or after creating a new environment from scratch?

My pleasure @jtp.

This happened after rebuilding a conda environment from scratch. After leafing through the issues you referenced, I went to my iMac and rebuilt the same conda environment to check whether I could see the same issue there with Chrome. Turns out everything worked fine. This is actually making me wonder if this issue has emerged because I recently switched from running this Python stack in an emulated mode on my M1 MacBook Pro to native mode. Not sure how those would be connected but I wanted to mention it. This included reinstalling homebrew natively. Happy to check anything you might think is helpful or informative.

I had the similar error on M1 mac, chrome.

Things that I tried that did not work:

  • disable all extensions
  • clear local data (cookies, local storage)

I could solve it by doing an empty cache + hard reload (open developer toolbar, right click on refresh button and empty cache and hard reload).


Thank you for this @SiggyF! I probably never would have considered emptying the cache as something needed here. I did just that and it finally loaded in Chrome.

1 Like