Jupyter Not Finding Folders

I have a github project that I cloned to my home pc, but when I try to open it with Jupyter it only detects a file from very early on in the project before I did any of the work.

I can’ t find the same file that Jupyter is finding in my folders and jupyter can’t seem to find the folders that I have in my file explorer. I’ll attach pictures to explain.

If you look at the picture there should be way more files in there. In fact, there should be folders with the projects that I’m trying to complete and then I can drill down those folders to the jupyter doc. But for some reason all I get is this jupyter doc of the project several different github commits ago. Jupyter is seeing something totally different than what is actually in my file explorer.

I’d post pictures, but new users can’t post more than one photo. I can’t for the life of me understand why Jupyter is seeing something completely different than what file explorer is seeing.

Any and all help would be appreciated.

Hi @direnc88

A couple of followup questions:

  • Are you running Windows, Mac, Linux, or ?
  • How did you install Jupyter Notebook? Conda, pip, from source, etc.?
  • If you click on the folder named “..” what do you see? This should take you to your home folder. Does this match your file system?

My hunch is that you may be starting the notebook server in a different location than you expect.

My apologies, I solved this problem later that night and I didn’t remember to delete this post.

I thought I was starting the notebook server in a fairly high up file system so that I could access most file. From where I was I could access almost any file on my pc. Long story short: MS OneDrive has really thrown me off and I’ll need to look further into how my files are set up.

Sorry to bother you.

1 Like

Hi. How did you solve this problem?

I had the same issue. MS One Drive storing some files in Documents within and others in Users/My_name/Documents. How did you solve this?

Hey I found out why I couldn’t find anything. Microsoft OneDrive created a new folder in my user account called “OneDrive” and moved all my desktop, documents, and pictures to that folder. My true documents folder WAS actually empty when it didn’t used to be. Very annoying.

1 Like

Hello,
I am having the same/similar problem. Jupyter is not seeing the same files and folders as I am seeing using windows file explorer. For example when I look under my Desktop folder Jupyter sees only one folder when there should be four. How did you solve the problem?

Did you find a solution? I have the same / similar problem.

Go into the one drive folder first instead and the desktop folder should be in there with all the folders missing from the other desktop folder inside

Yes Onedrive appears to have messed everything up even after I turned it off now I have a desktop under users and a desktop under onedrive. The location my PC is automatically looking now is at the onedrive folder.

1 Like

Hi everyone!! Look for the folder called onedriver from your jupyter notebook browser!! The folders such as desktop and documents should be found there. Hope this helps!! :smiley:

4 Likes

^This was the solution for me. OneDrive backups move your files to the OneDrive folder. Find it in the file directory and you should see all your stuff again. Wish they had mentioned this small detail of backing up files so I didn’t waste an hour of my day haha

2 Likes

I dont even a onedrive folder

Hi all,

Jupyter is really great, thanks to all the people involved. Did you find any solution to this issue? I’m facing the same problem now. JupyterLab (conda 4.10.3, anaconda Command line client (version 1.7.2)) is capable of looking within my workstation (MAC) but it cannot look within the OneDrive. Unfortunately, I don’t store files locally. JupyterLab finds OneDrive folder but that’s the end. If I provide the complete path I can import the file from OneDrive but I need to navigate using the left side folder navigator (which it’s frustrating). Do I need to give some sort of permission to Jupyter to access the cloud folder? Sorry, I am far from being an informatician.

Thanks a lot, great job!!
Andres

Similar problem I am facing. I installed anacondas Jupiter in my system and I was working on many Jupiter files etc. Later I moved many folders from the C-drive to other drive. Then when I opened Jupiter I am not able to find any of folders & files.

How to rectify this issue. Please help.
Thanks
JK

I found a solution to this issue in this stackoverflow thread: python - Open Jupyter Notebook from a Drive Other than C Drive - Stack Overflow

Basically, what happens is that Jypyter Notebook/Lab can only access one driver at once. My Onedrive was on my D drive, but Jypyter only opened the C drive.

I solved it by using anaconda prompt (should be installed if you have anaconda navigator), and typing the following command

jupyter notebook --notebook-dir=D:

This command opens jypyter notebook with access to the D drive, but not the C drive.
The thread i linked has more in depth explanations and perhaps also an answer to accessing both drives at once, but i was too lazy and didn’t read further.

1 Like