Jupyter nbextensions configurator

So I’ve had a jp-nb session open for about 2 weeks straight now, everything was working as it should. Kept having issues with modules not found error in jp-nb in the past and present, basically this link sums up my issues, Installing Python Packages from a Jupyter Notebook | Pythonic Perambulations, tried all the work arounds, but I work only in a venv, so I would never pip install packages in the note books but rather in the venv, due to the fact I use the note book more for ease of interaction then convert it to a .py file, so essentially use jp-nb then can tear it down if needed, so I don’t want too much dependancy in the nb. Got fed up of the whole module not found error, and my work around of appending the venv site packages to the sys.path, so went deep into trying to figure out the issues (thus landed on that link above). Settled on the 'python -m pip install {package} ’ invoked from venv (virtualenv), to see if it will resolve the issue, didn’t work first time then it did so lets assume it did work, now got a different error. The pip installation of jp-np completes with no errors reported, but when I launch with jp-nb in my venv with command ‘jupyter notebook’, I see these server errors (listed below) and now when the browser (default: chrome) is auto launched, it never loads the home page (jp-nb file browser) with localhost:port/tree pre-embeded, even if I use the tokenized links in that same tab that was auto-launched, with local:port/tree?token=, it doesnt work, it only works with loop back address imbedded Which I am fine with however dont want to run into issues later because of the error report in the jp-server.
To resolve the ‘jupyter_nbextensions_configurator’ error, I tried dumping the venv and reloading, I tried pip re-installing jp-nb then tried installing from source (not wheels), then tried to just to reinstall install ‘jupyter_nbextensions_configurator’ by itself but the error keeps persisting. Im assuming its referring to some sort of chrome extensions? Any ideas? Much appreciated…
jupyter_nbextensions_configurator | error adding extension (enabled: True): The module ‘jupyter_nbextensions_configurator’ could not be found (No module named ‘jupyter_nbextensions_configurator’). Are you sure the extension is installed?
Traceback (most recent call last):
File “/usr/local/lib/python3.11/site-packages/jupyter_server/extension/manager.py”, line 319, in add_extension
extpkg = ExtensionPackage(name=extension_name, enabled=enabled)
File “/usr/local/lib/python3.11/site-packages/jupyter_server/extension/manager.py”, line 183, in init
File “/usr/local/lib/python3.11/site-packages/jupyter_server/extension/manager.py”, line 198, in _load_metadata
raise ExtensionModuleNotFound(msg) from None
jupyter_server.extension.utils.ExtensionModuleNotFound: The module ‘jupyter_nbextensions_configurator’ could not be found (No module named ‘jupyter_nbextensions_configurator’). Are you sure the extension is installed?

Not sure why I cant edit the original post. So I figured out what was going on, when I ran (venv) python -m pip install jupyter notebook, the new version 7 was being installed. From the website:
Version 7 of the Jupyter Notebook application might break your extensions or other customizations. Please read this page to find out if you need to take any actions to ensure a smooth, uninterrupted experience.
Here is the short form of the fix: (venv)$ python -m pip install nbclassic
from → GitHub - jupyter/nbclassic: Jupyter Notebook as a Jupyter Server extension
details–> Frontend Extensions in Notebook 7 — Jupyter Notebook 7.1.0rc0 documentation
So i pip uninstalled jupyter notebook and then python - m pip installed nbclassic.
Still getting errors on auto-launch but the notebook is successfully loads the home page file browser and I can open the ipynb file.
The above warning is also imbedded in the web page, I research when I have time. Not sure what extensions I had running that broke this, dont have time to check now as I am behind on work because of the issues, if anyone reports back I’d love to hear your thoughts.