Ground up / bare metal installation of JupyterHub

I tried installing JupyterHub on a Raspberry Pi 4 using Ubuntu Server 20.04 LTS with the manual methode from Install JupyterHub and JupyterLab from the ground up — JupyterHub 1.3.0 documentation
(I tried the manual way because the tljh-script stuck at the point creating the systemd service as far as I can tell by the manual uninstallation process.)

1st probleme:
I stuck in part 2 at:

sudo apt update
sudo apt install conda

Update throws an error that the public signature of conda package could not be varified (NO_PUBKEY).

If I go to https://repo.anaconda.com/pkgs/misc/debrepo/conda by browser it shows an 404 error message. Is this part of manual installation outdated?

2nd probleme:
I was not able to active JupyterLab as default user app in jupyterhub_config.py by setting

c.Spawner.default_url = ‘/lab’

in line 811 because it ended with an error trying to start the systemd service.
(Starting JupyterLab manual by changing URL from ‘…/tree/…’ to ‘…/lab’ succeeded.)

1 Like

“Solution” to 1st probleme found:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys {KEY IN ERROR MESSAGE}

Unfortunately there is no ARM Version for conda…