Font size for cells on notebooks in JupyterLab

Hello
I am using Jupyterlab version 3.2.1
Under settings you have the possibility to increase or decrease the font size. This feature doesn’t work.
I’ve been trying repeatedly “increase Text Editor font size” but I see no change.
I did change the settings with Crtl+, and you see the values assigned to the font size on the right panel “User Preferences”. Only the output cells did increase in size but not the markdown cells.
Question 1: how can you change the parameter values in the left panel “System defaults”
Question 2: how can I change the font size of the markdown cells too?


thank you for an answer!

If you are looking to change the notebook, “increase Text Editor font size” (found under the ‘Settings’ menu at present) is not what you are after. The text editor is the editor you get when you go to ‘File’ > ‘New’ > ‘Text File’.

I don’t know what you mean by CTRL+. Maybe on your machine that is linked to “increase Text Editor font size” as a shortcut? Doesn’t seem to do anything on my machine running a remote launch, see below.

As for:

I’m running JupyterLab 3.1.2 via here and what works there is copying the content the ‘System Defaults’ tab over into the ‘User Preferences’ tab and then changing and saving with the Command-S shortcut. (Or you can use the disk drive icon in the upper right.) Following saving, it takes effect over in the notebook.

Ctrl +, is the command to open the Settings menu. You did put a point instead of a comma!
Could you explain the purpose of “increase Text Editor font size" under the Settings menu?
Do you know the answer for question 2?
Even changing the parameter value for “markdownCellConfig”:{“fontSize”: 10}} has no impact on the markdown font size.
thank you

Oh yes, I missed that comma. I understand you meant open the ‘Advanced Settings Editor’ now.

I did explain the purpose of “increase Text Editor font size" is to adjust size in the text editor. To see it in action launch from here and then open the file lorenz.py from the file navavigator. Now use the menu option ‘Settings’ > “increase Text Editor font size" a few times and it will keep increasing.

“markdownCellConfig”:{“fontSize”: changes the markdown editor display as you are editing. Increase it dramatically and then edit your markdown cell.

OK now I see the purpose of “Text Editor font size”!
With “markdownCellConfig”:{“fontSize” } you only change the markdown editor display as you are editing but what about changing the font size of the markdown cell permanently–> the result you see
thank you

Options are discussed here in reply to cocoaaa ,who posed your question. The option that telamonian points out has moved in version 3.2 to Settings → Theme → Increase Content Font Size. Using that now, it didn’t seem to do much very fast, but I think it had changed the setting that buggyprogrammer describes. It was much more straightforward to demonstrate by adjusting to extremes using buggyprogrammer’s method, rather than advancing or decreasing slowly.


Related to that, I came across a way to temporarily adjust sections in the rendered display of the markdown cell that I’ll note here as well because it may be helpful to emphasize only certain parts.

I base this example on what is shown here, I’m using the session launched from here still:

# THIS IS A TEST

<font size="12">your_text_here</font>

Compare rendering with the following in another markdown cell:

# THIS IS A TEST

<font size="6">your_text_here</font>

And then another to compare to a third markdown cell:

# THIS IS A TEST

<font size="3">your_text_here</font>

thank you.
Why not using “markdownCellConfig”:{“fontSize” } for the font size in markdown cells insteal of using it for the markdown editor display. this would be much more useful.
Thank you

I couldn’t tell you. I’ve noticed with JupyterLab issues like this usually has to do with legacy issues. JupyterLab opens up so much more customization. And a lot of users want consistency between the classic notebook interface and JupyterLab. In other words, what I put in a cell will give same output or rendering if it is in classic notebook or JupyterLab. So I cannot tell you why “markdownCellConfig”:{“fontSize” } effect the size of the font for while you are in editing mode. But I imagine you need a setting for that and that’s the one. I don’t know why there isn’t a definite separate setting for markdown rendered content in the notebook cells. However, most likely if you are scaling the size of the code output, you want the output from markdown scaled too and so it is the content setting. (Just guessing here.) Plus there’s the ‘zoom’ setting on the browser and so maybe some thinking was fine-tunining scaling that way is moot. I’ll note the markdown preview settings in JupyterLab have there own settings file and everything is straightforward like you are wanting. The settings in ‘notebook’ settings are much more tied to previous tech and practices.

If you really need an answer to your last post, I would put it as a new post.