External-Ip pending despite having nginx-controller and metalb installed and running with external ip on nginx-controller

I’m not able to get jhub working with external ip, see the info:

k get svc -A
NAMESPACE                NAME                                             TYPE           CLUSTER-IP       EXTERNAL-IP   PORT(S)                      AGE
default                  gpu-operator-1606212060-node-feature-discovery   ClusterIP   <none>        8080/TCP                     5h31m
default                  kubernetes                                       ClusterIP        <none>        443/TCP                      6h45m
gpu-operator-resources   nvidia-dcgm-exporter                             ClusterIP    <none>        9400/TCP                     4h44m
ingress-nginx            ingress-nginx-controller                         LoadBalancer    my real external IP 80:30144/TCP,443:31509/TCP   40m
ingress-nginx            ingress-nginx-controller-admission               ClusterIP   <none>        443/TCP                      40m
jhub                     hub                                              ClusterIP    <none>        8081/TCP                     7m15s
jhub                     proxy-api                                        ClusterIP    <none>        8001/TCP                     7m15s
jhub                     proxy-public                                     LoadBalancer    <pending>     80:30355/TCP                 7m15s
kube-system              kube-dns                                         ClusterIP       <none>        53/UDP,53/TCP,9153/TCP       6h45m

I’m wondering why jhub proxy-public is still pending…

Accessing in a browser: http:// my real external IP give me nginx error, but it means nginx is accessible from outisde.

Ok some news now. If I add one more ip in the Metallb pool, it get added to the proxy-public. But then my question is, how to use nginx controller only to access the jupyterhub hub ? Because then I have to use another ip…

and my jupyterhub config like in the doc:

  secretToken: 'MYTOKEN'
    enabled: true
      - my_real_ip