Error creating: pods "hub-b564f4485-" is forbidden: unable to validate against any pod security policy: []

Hi,
On a on prem cluster(installed with Gravity: https://gravitational.com/gravity/docs/cluster/#pod-security-policies) with security policies, I’m trying to do a helm install of the Zero to Jupyterhub helm chart and I encounter the following error.

Error creating: pods "hub-b564f4485-" is forbidden: unable to validate against any pod security policy: []

I’m on version 0.8.2 of Zero to JupyterHub

I have existing privileged pod security policies(all powerful, can do everything) that I can attach(to a serviceaccount for eg.) or set if required. Please let me know. Ref: https://gravitational.com/gravity/docs/cluster/#pod-security-policies As you can see there, there is a PSP privileged which allows unrestricted use to the cluster.

1 Like