Download of file from JupyterLab fails

I’ve deployed a JupyterHub on the cloud using Z2JH, and while I know that at some point I’ve been able to download files from within JupyterLab by rightclicking on a file and pressing download. I can no longer do it and I’m not sure what has changed since it worked. I have probably updated JupyterHub and JupyterLab and many others things since it worked.

The associated logs from the jupyter-notebook server is a single line warning:

[W 2019-03-29 09:07:23.958 SingleUserLabApp handlers:422] Blocking request with no referer

My Jupyter Lab version is 0.35.4, my Jupyter Notebook version is 5.7.6, and my Jupyter Hub is 0.9.4 on a quite recent z2jh helm chart release but before 1.0.0b1 was introduced some days ago.


I did some more googling and found this issue: https://github.com/jupyterlab/jupyterlab/issues/6106

1 Like

I learned that this issue is for Chrome users right now, and tied to version 5.7.6 of Jupyter Notebook. A suitable workaround for a user wanting to download files is to use Firefox for the time being.

As this has now become an issue to fix rather than a question, and it is already tracked, I’m closing this by marking this post as the answer.

3 Likes

DId you start Jupyter lab with --ip=0.0.0.0?

The same thing happened to me, but I realized it was because I was accessing Jupyter lab at http://0.0.0.0:8888 rather than using an actual IP address or hostname in place of 0.0.0.0.

1 Like