Docker Jupyter/datascience-notebook not accepting token

For nearly a year I have been running notebooks based on the datascience-notebook image. This has been no problem at all, and over time I have added new python packages. However, after a recent build, I find I can no longer log in using the token. Copying the token from the log and entering it on the page doesn’t work either. Has something changed in the docker images? I tried opening a terminal in the image and typing ‘jupyter server list’ and it returns nothing.

My Dockerfile is
FROM jupyter/datascience-notebook
USER root
RUN conda update -n base conda
RUN conda install --yes --name root psycopg2
RUN conda install -c conda-forge --yes --name root redis rq
RUN conda install --yes --name root pymongo
RUN conda install --yes --name root pyodbc
RUN conda install --yes --name root pyarrow
RUN pip install xgboost
RUN pip install PyMySQL
RUN pip install comet_ml
RUN pip install hiplot
RUN conda install --yes --name root nltk
RUN conda install --yes --name root spacy
RUN conda install -c conda-forge --yes --name root transformers
RUN pip install data_describe
RUN conda install -c plotly plotly=4.14.3
RUN conda install folium -c conda-forge
RUN conda install -c conda-forge --yes --name root dnspython
RUN [“bash”, “-c”, “source activate root && pip install rq-dashboard”]
USER jovyan

and the relevant part of the docker-compose file is
version: ‘3’
build: docker/jupyter
- postgres
- mongo
- docker/jupyter/jupyter.env
- “8888:8888”
- .:/home/jovyan

Any ideas on why this has stopped working? Something to do with the move to jupyterlab, perhaps?

Solved. I didn’t find anything that was holding on to but something must have, because restarting solved the problem.

1 Like