Conda-develop appears to have broken my account

Hey folks - I seem to have painted myself into a corner and I’m hoping someone here can point me in the right direction.
To be as brief as possible:
I setup an instance of littlest jupyterhub and integrated with AD via cognito. So when a user logs in for the first time, using their AD credentials, an account gets created.
I logged in using this method, and did some conda install commands, and then installed conda build and did a “conda develop” command, attempting to put some custom libs on everyone’s path.
The moment I ran the develop command, my terminal session (via browser) froze.
I tried several new sessions, but they all showed me an empty window.
My notebooks also stopped connecting after this.

Then, I tried deleting and re-creating my account to see if that would get me anywhere, but now the re-create step fails. I get “Spawned failed - timeout”.

So at this point I’m feeling really hamstrung. I tried, via ssh, to delete my whole folder from /home/ and that didn’t help.

Can anyone with some expertise here point me in the right direction?

First step is: what extra step(s) am I missing in deleting my account so that I can re-create it?

If you followed the TLJH guide and used a virtual machine the easiest solution is to delete the VM and start again. If you’ve already got any important files there remember to back them up first.

There are lots of things that could have gone wrong- forcibly deleting your user and home directory will unfortunately have made things worse. If you can’t recreate your server then if you tell us exactly everything you did step-by-step we may be able to help, but no guarantees.


I did not use a VM, so if you see anything obvious in my steps here, please let me know!

After conda-develop, I:

  • delete the .conda file in my /home/ account (didn’t help)
  • restarted TLJN (didn’t help)
  • logged in as a different user and delete my account
    • this did NOT delete the account data under /home
    • when I logged in again, it “worked” but I had the exact same issues
  • deleted my account again and this time delete the data under /home/
    • this time, when I logged in, it failed to create my account
  • also manually removed myself as an admin user via cli “remove-item”
  • restarted
  • still having the same issue - nothing interesting in the log file except a timeout message

The other accounts on the system still work fine. But because we tied it to AD, I can’t just create a new account. I would like to re-create my account.

Thanks in advance.