Can push but not pull images


I am using Google’s container registry to store my images. I have deployed BinderHub successfully and when I try to launch a binder the image is built and pushed correctly because I can find it in my Google Container Registry.

There is a new pod created but it goes into Failed state because it is unable to pull the new image. The error:

Does anybody have an idea how I can solve this please?

Does somebody have a clue please? It’s done on a bare-metal kubernetes and I’ve added a image pull secret for my registry.

Can you post your config.yaml and secret.yaml files (secrets removed!) please? This will give us a starting point to help you. Thanks!

Today I finally solved the issue. The problem was the following: I have a bare metal K8s cluster so I manually had to create an image pull secret. My secret allowed to pull from but my image prefix had I changed my pull secret from to and now I can pull perfectly. I first tried the other way around by setting the image prefix to but that didn’t work for a reason unknown to me.