Blocking Cross Origin request from https://mybinder.org/

Opening the following link : Binder

throws the following error:

Using jupyterbook for building, using the following steps for integrating binder

Any help will be appreciated,
Thanks.

That error you are seeing isn’t overly informative in your case. I can sort of decipher what the underlying issue is; however, I don’t yet know how to fix it.

The underlying symptom is that Myst markdown format is NOT coming up with the option to open Myst markdown as notebooks. For an example of one that works to do this, launching a binder session from here takes you to JupyterLab and if you right-click the file cheatsheet.md (in ‘book’ directory that opens by default) to bring up Open With.., it lists letting you open in it Notebook. I don’t have that option when I try to open your Myst Markdown file within JupyterLab accessed from your link. By the way, in case you don’t know this, once you are on that 403 page that you are seeing, if you change the end of the URL from files/book/content/basic_population_model.md to lab, so that you can get to JupyterLab to troubleshoot a bit like I describe in yours. Or you can go to classic notebook mode if you change the end to tree.(Triggering launches in classic is what you are most likely ultimately going to want to do here because JupyterLab won’t open Myst Markdown directly at this time.) In sessions launched from your repo, Myst markdown isn’t being handled like Myst Markdown in sessions launched via that other example repo. And so when I think you use your Binder launch URL it fails because there is no ability to open your Myst markdown as a notebook in sessions launched from your repo.

Something about your environment is different than the example I referenced; however, I cannot yet pinpoint that critical difference myself. (I do note the one what works is using jupytext~=1.7. And the one that works has a detailed postBuild in the binder directory.) Sorry I don’t have the solution at this time. I haven’t tried this Myst markdown feature via MyBinder before this. But I’m sharing this with you because maybe at least better understanding what is going on will help get you closer to the solution sooner.

I did try opening the cheatsheet.md file in sessions launched from your repo and still didn’t get the Notebook option and so the backing kernel differences in the Myst markdown aren’t the underlying difference.

By the way, I found that example by looking at the Gallery of Jupyter Books linked from the documentation and clicked on going to the repo for one and searching for ‘myst’ in the repo and seeing it in markdown for a file there in the first one I tried. And then I tested it opened as the documentation said it should. I don’t know if other examples may exist that are more along the lines of your ir kernel based markdown.

4 Likes