Binder startup stuck at "Pulling Image"

Starting up my repository get’s stuck at “Pulling Image”. I experience the same error with the Qiskit repository which might be the source of the error. What could be the problem?

See the reply here and the blog link referenced in this similar reply for a better understanding of how capacity on MyBinder is an ongoing issue at present.

That being said, your repo GitHub - eclipse-qrisp/Qrisp: Qrisp - a framework for high-level programming of Quantum computers launches and running from qrisp import QuantumString in the first cell of a new notebook runs just fine.

tbh I don’t understand your answer? Is it working for you?

The link you posted is about a reduction in capacity that happened in May 23. Our repo ran fine until about one week ago. Also I am able to reliable start for instance GitHub - networkx/networkx: Network Analysis in Python

EDIT: It works now (idk why - Hope it’s not temporary). Thank you for your help

Yes, as I said it launches a session and in that session I can import qrisp. This is consistent with your own edit.

It may well be temporary, subject to capacity, traffic, availability of nodes, etc… However, it failing to launch a session should also be temporary.

I know the link is from May 23 of this year. If you search issues dealing with the MyBinder, you’ll see more recent posts continuing to say much the same thing as the issue continues due that significant loss of computational resources. That member of the federation generously carried the bulk of the capacity of the public MyBinder service up to that point.

1 Like