Binder no longer builds my repository, saying 'failed to connect to event stream'

Just 5 days ago, Binder was working fine with my repository. Now when I tried to launch it after making a few minor edits to my programs, it won’t even start building. It just says, ‘failed to connect to event stream.’ What’s going on? I’m new to Binder, and I read another post on this issue but couldn’t figure out how to apply that to my problem. I appreciate any advice you can provide me on this matter. My repository is
Thank you!

Usually ‘failed to connect to event stream’ just means a temporary glitch in communication to the log stream. Reloading the page will usually let you reconnect with the build status messages.

I just had your repo successfully build and launch via your launch binder badge.

Thank you for replying. I’ve attempted to reload it several times. Do you recommend waiting a few hours? It occurred to me that although GitHub says it’s updated, it might still be processing my programs.

1 Like

GitHub reports your latest push was about 15 minutes ago. Normally once github has you push, launching will trigger a new build. No need to wait.

As for reload failing, maybe try launching a different Binder repo, clearing cache in browser, or trying with a different browser or device. Or maybe try to change url you are using to connect into a specific notebook? Just sounds like your browser glitched and isn’t capable of catching update.


Clearing my browser cache for the site worked. Thank you very much for your clear, helpful and prompt response. Like I said, I’m new to this site and wasn’t sure how serious this error was.