'AppOptions' object has no attribute 'all' when rebuilding lab

After a recent update to my conda installation, when I tried to rebuild the extensions on jupyter lab, I got the following error:

[I 19:59:56.504 LabApp] Building jupyterlab assets (build:dev)
[W 20:00:12.615 LabApp] Build failed, running a clean and rebuild
[I 20:00:12.663 LabApp] Cleaning /anaconda3/share/jupyter/lab...
[W 20:00:12.664 LabApp] 500 POST /lab/api/build?1591833596037 (::1): 'AppOptions' object has no attribute 'all'
[W 20:00:12.664 LabApp] 'AppOptions' object has no attribute 'all'
[E 20:00:12.664 LabApp] {
      "Host": "localhost:8888",
      "Pragma": "no-cache",
      "Accept": "*/*",
      "Authorization": "token a5b82991cd65518856647cc390f4cd18ee3f34f27ed282ac",
      "X-Xsrftoken": "2|259e0022|5985556f9db52b97977c8c274bd79abc|1591833496",
      "Accept-Language": "en-us",
      "Accept-Encoding": "gzip, deflate",
      "Cache-Control": "no-cache",
      "Content-Type": "application/json",
      "Origin": "http://localhost:8888",
      "User-Agent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.1 Safari/605.1.15",
      "Referer": "http://localhost:8888/lab",
      "Content-Length": "0",
      "Connection": "keep-alive",
      "Cookie": "username-localhost-8888=\"2|1:0|10:1591833590|23:username-localhost-8888|44:YjVmMWE2ZTk0NzJiNGJiNTkzMjU5ZDIxODNiYzI4ZDA=|dd122bb84db4a4921153ed08569cd5d5ec6d20d67931f00c6188f411879906ec\"; _xsrf=2|259e0022|5985556f9db52b97977c8c274bd79abc|1591833496"

I’m looking for any suggestions on how to resolve or further diagnose this issue. The server itself continues to work ok.

1 Like

Did you ever find a solution to this issue? I’m also getting the same error.

Nope, still unresolved.

I finally decided to just blow away my conda installation and start over. That seemed to fix the problem, but it’s not really a solution.

Had exactly the same issue. The error message is pretty non-descriptive…

I ran ‘jupyter lab build’ from cmd line got a ‘build failed’ message and checked the generated log file (path shown in the error message). In my case it turned to be an issue with ssl-verification in yarn (called during the build).

After an easy edit of the yarn config the issue was resolved. Ran ‘jupyter lab build’ again, now successfully.