Able to do everything but cannot create notebook!

Hi, have “500 internal server error” while trying to create a notebook inside fresh installed jupyterhub(running with systemctl). Does anyone have any assumptions about the root of this error?
Nothing in journalctl logs, even do not know how to debug this. Checked kernels, but they are good, created different ones, and have the same error.

Hi! Welcome to the forum.

Could you give us more details about how you installed and configured JupyterHub? Please give as much information as possible, including your config file with secrets redacted and all the installation steps you followed.

The more information you provide the more likely it is that someone will be able to reproduce or solve your problem.


I have installed it using this and this

config is the default one

Found this in my browser

The “Install JupyterHub and JupyterLab from the ground up” doc is intended for people who want to understand some of the low level details of installing JupyterHub. If you’re relatively new to installing JupyterHub I’d recommend one of the production installation guides instead.

The Littlest JupyterHub: A simple JupyterHub distribution for a small (0-100) number of users on a single server sounds like it’d be suitable, though if you want something that scales to a larger number of users see Zero to JupyterHub with Kubernetes.

1 Like

I’ve checked everything that I think can have influence oт jupyterhub on a low level and I am more familiar with low level btw. So it will be good to have some advice from someone who had the same error, or who knows how to debug such errors.

Great! Good luck with finding the answer, it wasn’t clear from your original post you were already quite knowledgeable about JupyerHub :slight_smile: