Workaround?: Python 3.6 support dropped but crucial for certain python package

Hi guys,

I read HERE that the support for python 3.6 was dropped this year.

Now I’m facing a big problem. In my institute we are depending on a package (LINK) which requires python 3.6.
We have a running jupyterhub on a cloud-based virtual machine since the beginning of this year.
Evrything works proberly there…

Now we wanted to start more virtual machines. Unfortunately it does not work anymore with the current version of TLJH, because py 3.6 was dropped.

Could anyone share a workaround or solution that we can still use a py 3.6 environment on the latest version of TLJH?

1 Like

The link you posted to an earlier discourse on this forum was about nbconvert which is a package used for conversion of notebook into other formats (like PDF, HTML, etc).

TLJH seems to still be tested on Python 3.6 (as of today):

Did you encounter a specific problem?

More broadly, I believe that most of Jupyter sub-projects still support Python 3.6; some sub-projects/packages may not be releasing new major versions for 3.6 (so only older versions are supported on old version - which makes sense).

However, the Python 3.6 will stop receiving security patches in 3 weeks and 2 days (23 Dec 2021). I would highly recommend making the package you depend on compatible with newer versions of Python (or maybe it is already compatible? the website you linked only mentions that newer versions are not supported, not incompatible).


Dear @krassowski

Thank you very much for your answer.
Unfortunately the package is not working with newer versions (I do not know why).

I also encounter a specific problem in our new Jupyterhub (Ubuntu 20.04. LTS, JupyterHub 1.5.0, JupyterLab 3.2.4). We don’t have this issue on our “old” Jupyterhub ((Ubuntu 18.04. LTS, JupyterHub 1.4.0, JupyterLab 3.0.16)).

I can create new environments and new python versions are working proberly.
However, when I create a python 3.6 environment I can’t work with the env. The creation is successfull, but when I try to apply a cell, there is a kernel error and even the code syntax is not highlighted.

Hope the screenshot clarifies the issue.

*** update/edit:
There seems to exist a workaround (LINK) regarding the use of the package snappy in newer versions, that I will try in the next days. However, It would be great to get the py3.6 env running anyway.


Thank you. I don’t have any immediate ideas as to why the Python 3.6 kernel does not start for you. If you could check the server logs to find what are the associated messages and if there are any tracebacks that would likely help a lot.