Text editor syntax highlighting does not work

Hi, I’m new to Jupyterlab.
I use the default Jupyterlab in Anaconda, with nodejs installed.
I just don’t know why the syntax highlighting does not work.
All language here is grey.

Did you click on the Text File tile under Other on the launcher first?

The one that comes up in launches from here via the launch binder badge is also greyed out when I don’t have anything open. If I click on Text file in the bottom row in the launcher of the session that will spin up, you should see the choices active when you go back to them in the menu.

The options under Text Editor Syntax Highlighting will also show up if you right click on a file in the navigator and select Open With > Editor.

It actually tries to use the extension and so if your file name extensions follow the usual conventions, it will already default to the correct syntax.

Hopefully yours behaves like the one that will come up in launches from the link I suggested.