Shift+enter in Skills Network Labs does nothing

Hello. I’m enrolled in the IBM Data Analytics certification and am learning, or trying to learn, Python at this point. My first hands-on lab task is to execute print(‘Hello Python!’) using shift+enter but the only thing that happens is I move to the next cell.
What am I missing? Where is this supposed to print? I place my cursor at the end of the code then press shift+enter and nothing. I’ve gone through about 4 more labs after this one and can’t execute anything can someone help me? A web search shows it seems to be a common problem but I can’t find a solution that doesn’t have code in I don’t understand. I’m using Edge but get the same result in chrome.
I apologize if this is the wrong place but it has “lab” in the name.

I’m assuming if you had included the useful kernel information in the upper right of your window, it would say Pyolite or Pyodide or something indicating it isn’t a typical full Python kernel?
If so, see what I wrote here to a questions that was much the same as yours. Especially about being patient when starting the notebook.

I don’t know what’s useful or not I’ve never used Python or Jupyter. No idea what a kernel is or what the gray circle meant until I saw a clear circle in Firefox just now. The shift+enter is working Firefox so I’ll just use that for the labs from here on out.
Thanks for the help.


1 Like

I am having this same issue. However, I have opened Jupyterlite in Chrome & Firefox and changed the kernels and shift + enter still does not work. I have opened and waited awhile then tried again. I am not sure what toi do can someone please help me. The post from fomightez did not help me at all.

Did you standard JupyterLite from the official site and not just the Skills Network?
Try from a different site, such as here?
Try a different computer with all these?
I used JupyterLite on a couple computers from the first two and they worked fine these last few days. All these times the initial set-up took a bit of time to let the kernel get ready.
Or just use MyBinder to run a full Python kernel at this point. Or install Anaconda Distribution on your system. The latter is the only one of these suggestions that will affect your local system. There’s lots of ways to use Python in Jupyter.

I would only suggest this as a last resort…
If you have your content saved independent of JupyterLite and you don’t mind, clearing your cache and cookies would ideally be in order. Keep in mind this will mess up signing in all things and so may be best to go to fresh computers to try what I listed above to see how a fresh system would be,