Hello. I deployed jupyterhub using helm chart v.2.0.0 and jupyterhub version 3.4.6. I get an error when doing a task. !!! I tried to set the jupyter notebook parameter --NotebookApp.iopub_data_rate_limit=100000000 when building docker, but I get ‘iopub_data_rate_limit’ has moved from NotebookApp to ServerApp. I went to change the file . I’ve been making c options.ServerApp.iopub_data_rate_limit = 100000000 and c.JupyterHub.iopub_data_rate_limit = 100000000 and the parameter is changed in /usr/local/etc/jupyterhub/config of my hub pod, but I keep getting the error. Can you tell me what I’m doing wrong? Is there a wrong directive or syntax in the configuration?

Config parameter iopub_data_rate_limit is on Jupyter Server and not JupyterHub. So, you can set it in your user home ~/.jupyter/ using c.ServerApp.iopub_data_rate_limit = 100000000.

1 Like

Can you tell me how to do this for helm chart? I can’t find where to apply this parameter.

I dont have a lot of experience on how to do it on Kubernetes context. So, I am not quite sure what is the best way to do it. Seems like extraFiles can be a way to do it?

Yup, extraFiles ought to work for this, e.g.

    # The file key is just a reference that doesn't influence the
    # actual file name.
      mountPath: /usr/local/etc/jupyter/jupyter_server_config.json
          iopub_data_rate_limit: 100000000

Thank you very much! You’ve made my life better. I hope this will be useful to other people on google))