Pip install jupyter[notebook] fails for Python 2

I just noticed that

pip install jupyter[notebook]

for Python 2.7 now fails with a message ending:

ERROR: Could not find a version that satisfies the requirement jupyterlab-widgets>=1.0.0 (from ipywidgets->jupyter[notebook]) (from versions: 0.3.2, 0.3.3, 0.4.0, 0.4.1, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.6.7, 0.6.8, 0.6.9, 0.6.10, 0.6.11, 0.6.12, 0.6.13, 0.6.14, 0.6.15)
ERROR: No matching distribution found for jupyterlab-widgets>=1.0.0 (from ipywidgets->jupyter[notebook])

Is this intended? If so, is there any way or providing a more informative error about dropped Python 2 support or similar?

Thanks for reporting this. It looks like an unintended consequence of the ipywigets 7.6 release. I’ve filed an issue for this at dependency problem with ipywidgets 7.6 · Issue #3049 · jupyter-widgets/ipywidgets · GitHub. To work around this until we get a 7.6.1, you should be able to specify ipywidgets 7.5:

pip install jupyter[notebook] ipywidgets==7.5

I just released ipywidgets 7.6.1 with a fix. Can you verify that things work for you now with ipywidgets 7.6.1?

1 Like

Thanks Jason - yes - that fixes it for me …