【Newbie looking for help】😭 about login warning, user control, kernel switching

In our campus network, I build a jupyterhub service (only accessed by campus inner IP).
I follow this tutorial to deploy jupyterhub without nginx. my jupyterhub version is 2.2.2.

It partly works. I meet several problems. :crazy_face::crazy_face::crazy_face:

:question:First, the login warning:
Warning: JupyterHub seems to be served over an unsecured HTTP connection. We strongly recommend enabling HTTPS for JupyterHub.


I use IP:port to login. I do not have SSL Certificate. How can I solve this warning?

:question:Second, I cannot control users login.
The jupyterhub_config is

c.LocalProcessSpawner.shell_cmd = ["bash", "-l", "-c"]
c.Spawner.default_url = "/lab"
c.JupyterHub.ip = ""
#c.Spawner.args = ["--KernelSpecManager.ensure_native_kernel=False"]

c.Authenticator.admin_users = set(['user1'])
c.Spawner.cmd = ['/opt/anaconda3/envs/jupyterLab/bin/jupyterhub-singleuser']
c.JupyterHub.port = 8888
#c.JupyterHub.statsd_prefix = 'jupyterhub'
#c.LocalAuthenticator.group_whitelist = {'jupyterUser'}
# c.JupyterHub.cookie_secret = bytes.fromhex('64 CHAR HEX STRING')
c.JupyterHub.cookie_secret_file = '/srv/jupyterhub/jupyterhub_cookie_secret'
# c.Spawner.notebook_dir = '/'
c.Spawner.default_url = '/data1/home/%U' # %U will be replaced with the username
c.Authenticator.allowed_users = {'user1', 'user2'}
c.Authenticator.whitelist = {'user1','user2'}

Although user3 is not in the c.Authenticator.allowed_users, user3 still can login. What should I set config to contrl users?

I also want to control the login by group. For example, I add user1, user2 and many other users into group1. Is any parameter to control group, like allowed_group?

:question:Third, when I use user1 to login, the default kernel is from environment jupyterLab.I use

conda create -n test1 python =3.8

to create an environment in

/user1 home/.conda/envs/test1

and I also run

python -m ipykernel install --user --name="test1" --display-name="test1".

I select the kernel is test1 in .ipynb , however, the package used in .ipynb is still from environment jupyterLab not from environment test1. How can I solve it?

Thank you very much! :smile::smile::smile: