Nbviewer not showing updated version of Jupyter Notebook

I had a typographical error in one of the Markdown cells in my program which displays an image. I’ve corrected it and it displays properly on GitHub and Binder, but not on nbviewer. I’ve tried it in multiple browsers, and the image is replaced by the line of code with quotation marks in the wrong space. Will nbviewer update the file eventually on its own, or do I have to do something to get it to display the updated version? I appreciate any insight you can provide into this matter.

Check out here - maybe this helps?



I had looked on that page for help, but must have overlooked that item. Adding flush_cache gave me an error the first time I tried it but since it’s been more than 10 minutes since the last time I attempted to view that notebook, I didn’t need to flush it. Thanks for the link, and sorry to trouble you with this.

1 Like

In general, I appreciate how helpful and responsive people on this forum have been - especially in cases like this where the solution wasn’t actually that complicated. Sometimes I post a question to a forum with the expectation that it won’t get answered - it’s sort of a backup whilst I attempt to solve it myself. This forum is definitely better.