Nbgitpuller links resulting in 404 errors

Hi - When using nbgitpuller link generator — nbgitpuller 0.1b documentation to generate links following the links pointing to a jupyterhub results in a 404 error if the browser session is signed in and running a server. If a server is not running the image selection form is displayed, then when selected the image loads and goes to a 404 page. The exact error is “404 : Not Found \n You are requesting a page that does not exist!” This is different from the “Jupyter has lots of moons…” error.

I have tried with a stock image from the jupyter registry, as well as a custom docker image with nbgitpuller explicitly installed without success. If I run jupyter serverextension enable nbgitpuller --sys-prefix in a notebook, it gives “Error loading server extension nbgitpuller is nbgitpuller importable?”. If I “pip install nbgitpuller” from the jupyter notebook, the previous command succeeds, but nbgitpuller links still result in 404 errors.

Since there are minimal resources with this issue it must be something stupid on my part. Does anyone have any insight?


Were you able to fix the issue? I’m facing the same problem, I created an issue but didnt get any replies.

My repo was working fine last year. This year I tried to use it again and I’m not getting 404. The weird this is I’m getting 404 when I try other binder links with nbgitpuller.