Mac/Chrome Browser, Can't connect to remote AWS EC2 Linux Server running Jupyter Notebook

Hello, I’m on a Mac, and Chrome browser. I have gone to AWS and created a EC2 instance with Ubuntu Server, and installed Anaconda and jupyter notebooks. I’ve properly setup and connect with SSH to the Linux server. I have setup the jupyter notebook, with gen config, created the cert, edited the jupyter config file, with correct added settings. But when running to check that I can on Mac running Chrome, to connect to the remote server running the jupyter notebook, it will not connect and error. I simply get: NET::ERR_CERT_INVALID. I have followed the course instructions to a ‘T’, and redone the process and still get the same outcome. I am following these instructions:

I was able to install the rest of other items like Java and Scala, etc onto the remote Linux server via the SSH connection no problem. I simply can not get my local Macn=book/Chrome browser to connect.

I also do not get the token or other ways to connect to present when I run ‘jupyter notebook’ at the Linux command prompt, I get this: and you can also see the errors I get when I try to connect and fail.

ubuntu@ip-172-31-41-246:~$ jupyter notebook [W 14:09:48.207 NotebookApp] Unrecognized JSON config file version, assuming version 1 [I 14:09:48.962 NotebookApp] [nb_conda_kernels] enabled, 1 kernels found [I 14:09:48.972 NotebookApp] Writing notebook server cookie secret to /run/user/1000/jupyter/notebook_cookie_secret [W 14:09:49.006 NotebookApp] WARNING: The notebook server is listening on all IP addresses and not using authentication. This is highly insecure and not recommended. [I 14:09:49.058 NotebookApp] ✓ nbpresent HTML export ENABLED [W 14:09:49.058 NotebookApp] ✗ nbpresent PDF export DISABLED: No module named ‘nbbrowserpdf’ [I 14:09:49.062 NotebookApp] [nb_conda] enabled [I 14:09:49.100 NotebookApp] [nb_anacondacloud] enabled [I 14:09:49.103 NotebookApp] Serving notebooks from local directory: /home/ubuntu [I 14:09:49.104 NotebookApp] 0 active kernels [I 14:09:49.104 NotebookApp] The Jupyter Notebook is running at: https://[all ip addresses on your system]:8888/ [I 14:09:49.104 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation). [W 14:09:53.928 NotebookApp] SSL Error on 9 (‘’, 40736): [SSL: SSLV3_ALERT_CERTIFICATE_UNKNOWN] sslv3 alert certificate unknown (_ssl.c:645) [W 14:09:53.934 NotebookApp] SSL Error on 10 (‘’, 33513): [SSL: SSLV3_ALERT_CERTIFICATE_UNKNOWN] sslv3 alert certificate unknown (_ssl.c:645) ^C[I 14:10:03.133 NotebookApp] interrupted Serving notebooks from local directory: /home/ubuntu 0 active kernels The Jupyter Notebook is running at: https://[all ip addresses on your system]:8888/ Shutdown this notebook server (y/[n])? y [C 14:10:04.996 NotebookApp] Shutdown confirmed [I 14:10:04.996 NotebookApp] Shutting down kernels

I’ve seen all the other posts about chmod, chown, vi the .config file, etc related to a post like this, and I’ve done all that, still stuck.

Please help!

Thank you

Has anyone here connected their local Mac/Jupyter to a remote VM on AWS/EC2 running the jupyter server?

After much effort, and working only with Chrome Browser on Mac on this course and specific issue, I tried FireFox Developer Edition, and after passing by the expected security warnings, it works as designed. Super awesome to connect my Browser to Jupyter running on a remote VM server in AWS. I plan to do something very similar but with Azure. Thanks for providing space for me.