Kernel dies when importing couchbase

Hello Everyone! I am runnning a Jupyterhub on a kubernetes cluster, and want to connect to couchbase using python, and doing some big data. I’m using python 3.11, and couchbase 4.1.4. Running the python interpreter everything works fine, but I need it to work from a notebook. When I run the importing parts as:

# needed for any cluster connection
from couchbase.auth import PasswordAuthenticator 
from couchbase.cluster import Cluster
# options for a cluster and SQL++ (N1QL) queries
from couchbase.options import ClusterOptions, QueryOptions

The kernel dies the image attached. Now in the pod logs I can see the following:


terminate called after throwing an instance of 'std::bad_cast'
  what():  std::bad_cast

Has anyone else encountered this kind of error?

I’m getting the same error when using the lib in a docker image

I’ve switched to version 4.1.3 of the python SDK, with that it gave me an openssl error, for which I used these commands in the notebook:
!sudo apt update

!sudo dpkg -i libssl1.1_1.1.1f-1ubuntu2.19_amd64.deb
!pip install couchbase==4.1.3

however, this is problematic, as the libssl version can change, and the link have to be manually changed, and the notebook can fail with getcwd error, and then you have to restart the notebook kernel