JupyterLab typing freezes for 5 to 10 seconds all the time

I have this very annoying problem working with Jupyter notebooks or JupyterLab notebooks (both have the same problem). Whenever I want to type in a cell, I try to click in it and I have to wait minimum 5 to 10 seconds for the cursor to show up and I can type a few characters. As soon as I hit enter to go to a newline, the same problem happens again. Finally, when I want to run the cell, even for simple code like “print(1)”, I have to wait another 5-10 seconds for it to complete.

I tried the following:

  1. Clear all cell outputs, refresh the page and try.
  2. I upgraded to the latest Jupyter version on python 3.7.x and I’ve tried to use different browsers (I.E., Firefox, chrome) without any impact.
  3. Restart the notebook, no effect.
  4. Tried both the barebone Jupyter notebook or JupyterLab notebooks. nothing changes the problem.

I am running with:

  • WinPython distribution winpython-3.7.4sp2 amd64
  • Jupyter 1.0.0
  • jupyterLab 1.1.4

Thanks for any suggestions

Chahé