jupyterlab-git extension is not loading on top of jupyerlab in TLJH jupyterhub container


I have a tljh jupyterhub container installed on a docker linux based.

On top of it, I have installed jupyerlab and jupyterlab-git using the below:
pip install --upgrade jupyterlab jupyterlab-git

Once I open my jupyterlab from the jupyterhub link, I am getting an error that jupyterlab-git is not loaded:

if I run jupyter server extension list on my container below is the result:

Config dir: /root/.jupyter

Config dir: /usr/etc/jupyter
jupyterlab_git enabled
- Validating jupyterlab_git…
jupyterlab_git 0.37.1 OK

/usr/local/lib/python3.6/dist-packages/jupyter_server_mathjax/app.py:40: FutureWarning: The alias _() will be deprecated. Use _i18n() instead.
help=_(“”“The MathJax.js configuration file that is to be used.”“”),
Config dir: /usr/local/etc/jupyter
jupyter_server_mathjax enabled
- Validating jupyter_server_mathjax…
jupyter_server_mathjax OK
jupyterlab_git enabled
- Validating jupyterlab_git…
jupyterlab_git 0.37.1 OK
nbclassic enabled
- Validating nbclassic…
nbclassic OK
nbdime enabled
- Validating nbdime…
nbdime 3.1.1 OK

Your help is much appreciated

What are the logs from the user server when it fails to load? That should show a traceback that hopefully points to what we need.

Hello @minrk ,

Can you specify from where I can get the logs you mentioned? is it from the jupyterhub container?

Thanks in advance

From the tljh docs:

sudo journalctl -u jupyter-<name-of-user>

But I may have an idea: you are using Python 3.6, and several packages have dropped suppport for that version of Python, so it’s possible that using a currently supported version of Python (>=3.8) will help.

Since you’re running tljh in Docker, is it possible that you can share your Dockerfile? That’s a pretty unusual setup, as tljh is designed to run on vms, not really in a container.

regarding the docker file, unfortunately we are not allowed to share such file within our organization. and tljh as per the below documentation can be installed on docker as container:

I can update python no issue.

I ran the journalctl but I am not able to attach the result

@minrk did I miss something?