Jupyter shows nothing, no files, no filder

jupyter was working fine in my side before. but after restart laptop, the jupyter suddenly not able to show files at all. shows empty. but it works fine before. (result is in snap 1 below). sorry for the in convenience, new user can only embed one pic,
then i run below command and just execute that file. it shows no such files. but the file definitely in that path.
(result is in snap2 and 3)

Anyone can help with that? i tried to change the default path of jupyter but no luck. but doesn’t matter which path it is using, at least i should be able to see some files there, shouldn’t be like snap 1 . hope someone can help me on this. thanks so much.


Could you expand on “was working fine” before? Had you been using it for long? And recently? Or was this the first time you restarted?

Maybe start troubleshooting by …
Spaces can be an issue for navigating / typing file names when on the command line, and so what is happening in ‘Snap 2’ isn’t that shocking. In your Windows file browser (‘Snap 3’) can you copy one of the files and rename it to a short name with no spaces, such as testcp.ipynb? Then back in your system command line interface (like in ‘Snap 2’) type, jupyter notebook testcp.ipynb. Did that open the notebook? (I’m assuming that has worked to open notebooks before?)
Do you see the new notebook when you type dir back in system command line interface (like in ‘Snap 2’) ?
(Suggestions here may help you in what else try.)

Another direction to try for troubleshooting…
From the Jupyter Dashboard that you show in ‘Snap 1’, open a new terminal using the New button on the right side. And in that type terminal type pwd. That should tell you where things are starting with the default working directory. You’ll want to see using ls and cd how to get from there to your directory with notebooks and that may inform you on how to do that in the dashboard.

Once you get the notebooks working again, you’ll be dealing with Windows-specific path issues calling file names from inside the notebooks. See here if you aren’t familiar with this. (The comment by furas here can help in understanding why this is so.)

Thanks so much for reply. i used jupyter yesterday. and got issue like that after restart. i restarted before , but don;t see this issue happen.
tried your another direction, and realized that the default is different directory. but we definitely have files in that folder as well. not sure why there is nothing.in the jupyter notebook.
below is when i try create a new terminal. thanks again for your reply.


Wayne via Jupyter Community Forum <notifications@jupyter.discoursemail.com> 于2022年8月19日周五 14:11写道:

You’ll need to see the links I put at the bottom so you can change directories without error because of the space characters (plus maybe the period in the directory name is problematic?) in your directory name. (As an aside, if you plan to do a lot of computational stuff, don’t include spaces in directory and file names and avoid anything that isn’t a letter as much as you can.) Start small by using cd to get the directory Alex in the Desktop folder. Then hopefully with dir you can see the 0. Jupyter directory.

You aren’t using OneDrive are you? (That has caused weirdness before because it moves files in a way that isn’t readily apparent.)

Thanks for the reply. for the naming issue, maybe that is not the reason. for the exactly path, it works all the time before. the issue suddenly occurred. i believe it may be something about permission. suddenly, python can not talk to the target folders. but that is just my guess. because with exactly same files name and directory, it works before. so apart from space/directory naming issue, anyother reason you could think about that will cause jupyter not able to see the files? thanks again for the help


Wayne via Jupyter Community Forum <notifications@jupyter.discoursemail.com> 于2022年8月19日周五 19:19写道:

i just realized, the python option is not available. it was definitely there before. so weird…

by the way, i saved all my jupyter files in the jupyter folder and when i try to create a new terminal and change the default path to C:\Users\xuecong.zheng\Desktop\Alex\0. Jupyter. it give me below issue. if i change default path to desktop, it allows me to do that. not sure why. then i change the files name and remove space and run command “jupyter notebook decision_tree.ipynb”. it allows me to run but the jupyter just spining forever and eventually give me " This site can’t be reached" error. any idea why?


Since you are using Anaconda, can you launch from the Anaconda navigator and then open the notebooks you want?

The fact you can change to the desktop and eliminate the spaces and then get the jupyter notebook command to be recognized says that a lot of your earlier stuff about parameters not being accepted and ‘No such file or directory’ errors were your path. (Note that where you put the blue question mark you still have a space in the file path that you aren’t following the advice I sent earlier to deal with and so syntax is wrong and it’s not going to work right.).
After getting the jupyter notebook command recognized successfully, the spinning forever and not being able to be reached though is a different issue, and of course all may tie back to why you cannot see files and folders inside Jupyter when it does work. Speaking of when it does work, if you want to continue trying to troubleshoot the current situation, can you say how are you getting inside Jupyter notebook to be at the Dashboard and take the picture you added here?

If at this point, you want to try something more radical, I’d say to review on this forum advice for uninstalling and reinstalling with Anaconda on a Windows Machine. Or if you maybe want an easier time of navigating the shell than MSDos, I’d suggest looking into running the Windows Subsystem for Linux (WSL) and installing the Anaconda distribution there.

Thanks so much sir. thanks for the help here for these days. i am really not sure what is going on here. just now, i tried your way to launch notebook using anaconda navigator as you suggested, it actually worked. really surprised. but then i tried again to launch jupyter notebook using normal way. it also successfully. seems as if the issue never happen before. really weird.
anyway, since the problem resolved itself, i think i am good now on my side. thanks so much for the help and your patience. really appreciate it.


1 Like