Jupyter Notebook not detecting GPU

We are running Jupyter application hosted on container(with base OS - ubuntu) on a VM server(CentOS). The GPU configuration seems fine as nvidia-smi and nvcc --version is working both on VM and as well as on container. But when I try the below block on jupyter, it’s returning ‘false’.

I am using TensorFlow commands to check GPU availability and its functionality.

import tensorflow as tf
tf.test.is_gpu_available()
tf.test.is_built_with_cuda()

Calling those last 2 functions provides with “false”.

If anyone can give me any directions regarding this, I would really appreciate it!

1 Like

GPU support must be enabled when Tensorflow is built. You’re using a CPU-only build of Tensorflow, as indicated by the second function you called.

If you’re using conda, install tensorflow-gpu or tensorflow-gpu-base.

Hi rolweber!

Thanks for the response! I’ve got tensorflow-gpu 1.14.0, same version as that of tensorflow. Its installed but I still am getting that error. Do I have to use tensorflow-gpu instead of tensorflow in that above code that I’ve posted to make it work?

Hey, i am also facing this error. Did you manage to solve this ?

Restarting the kernel, solved it for me.
If its still not solved try rebooting the system.