Jupyter Deployment on GKE fails with "default backend - 404"

I am attempting to deploy Jupyter on a GKE cluster using a Google Managed Certificate with IAP. The DNS is resolving but the redirect failed with “default backend - 404”.

Values file

        enabled: true
        type: offload
        - myhost
        type: NodePort
          http: 30080
          https: 30443
        labels: {}
          beta_cloud.google.com/backend-config: {"default": "iap-backend-config"}
      enabled: true
        - myhost
        kubernetes.io/ingress.global-static-ip-name: https-ip
        networking.gke.io/managed-certificates: https-cert

I’ve modified the proxy-public service to be a NodePort and created the ingress, which I have linked to a global static IP which the DNS is pointed to.

When I try to reach my domain it does not go through the IAP redirect but goes straight to the 404 error.

I would include more configuration details but it is preventing me from posting with “new users can only include 2 links in a post”. Not sure why that’s happening. I’m also having trouble formatting my config as yaml, the preformat does not seem to be working.

Thanks in advance,

On the substance of your question: I unfortunately don’t know the answer :frowning:

On the admin/forum side of things:

Welcome to the forum :wave: ! I used my admin powers to edit your post to get the config file formatted nicely. If you put three backticks, followed by pre-formatted stuff, followed by three backticks you should get the formatting you wanted.

The forum aims at building a community of active users that have civilised discussions (to quote the slogan of discourse). This means that what an account can do increases with time and interactions. One of these is how many links you can include in your first few posts. Limiting this helps with people making one off posts advertising their event, product, etc (they can’t link spam unless they take part in the community, which probably makes them less likely to spam).

In the end this forum is about humans talking to other humans. So one thread we have is Introduce yourself! which lets people introduce themselves (that way people become more human, not yet-another-forum-user) and it helps with gaining “points” against the forum software’s scoring system. Another good way to get “points” is to help out in an existing thread (basically paying it forward).

Thanks for your reply! I actually resolved this myself - the answer was that I tried enabling the ingress by setting ingress to “true” but that included a redirect

      - path: {{ $.Values.hub.baseUrl }}{{ $.Values.ingress.pathSuffix }}

This redirect was getting a 404 as it first was going through IAP which prevented accessing the page. I created my own ingress without this path and voila! It works!

In the meantime I have introduced myself on the humans thread. Great community you have here!

1 Like