IPKernelApp Error and Warning

I usually use the following command to start Jupyterlab:

jupyter lab --no-browser

After I start a browser, it immediately shows the following error and warning messages:

[IPKernelApp] ERROR | No such comm target registered: jupyter.widget.control
[IPKernelApp] WARNING | No such comm: 8d87f402-5faa-45c8-933f-e3560ac90fb7

Can someone please suggest how I can debug the error and warning? Thanks.

I am running Ubuntu 20.04.4 LTS on Windows WSL2. Jupyterlab version is 3.3.3 and ipython version is 8.2.0.

Hello kdlin1, assuming you work in a Python environment, can you please run $ python -m pip freeze and give us the resulting packages, their versions and whether this is a virtual environment (if so tell us what environment).

If you not working with Python, just issue $ jupyter --version on the cmd-line and edit your original post with the output.

If you solved the issue, please provide an answer for the community

I can reproduce this on an NVIDIA Jetson (aarch64) - it’ll take me a couple of hours to trim things down to a minimal example. It doesn’t seem to be affecting the operation of my applications. Also, this environment is frozen at Python 3.6, so “get a newer Python” is not a solution.

Hi, sorry for the late response. I use conda to manage the packages. Will your command still work?

I run Python 3.8.13. The same problem is still there.

It turns out this is an ipywidgets issue. It was fixed in 2017 but apparently some package constraint solvers still give a version that’s broken. See https://github.com/jupyter-widgets/ipywidgets/issues/1721. There’s a workaround here: https://github.com/jupyter-widgets/ipywidgets/issues/1721#issuecomment-330759036

You run that in your activated conda environment after you’ve installed everything.

It is unclear to me what one needs to do to fix the issue you mentioned. Could you please elaborate a bit?