Installing sagemath on tljh

So I’ve installed TLJH on a ubuntu22.04 vm. It’s working great, I have it exposed to the internet, installed letsencrypt, and some users. So far so good :slight_smile:

I want to install sagemath for some students to use as well, inside this Jupyter environment. I’ve tried to follow some instructions I found here.

So I started a terminal window and entered the following:

sudo -E conda create -n sage sage=10.1

The result is this:

jupyter-miguel@jup:~$ sudo -E conda create -n sage sage=10.1
Collecting package metadata (current_repodata.json): done
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): / Killed

This server has 2GB of RAM. Is that the issue here? Or something else going on?

Replying to my own post…

So I tried:

sudo -E conda create -n sagemath 

and it seemed to install. But not sure how to make it show up in the kernels.

1 Like

One more reply to myself. Ok, so since I was using a fresh ubuntu install, I didn’t actually have sagemath installed :frowning:

So a simple

sudo apt install sagemath

and then a reboot, and it works just fine.