Installing jupyter notebook as a user instead of local admin on windows and integrating with Antlr

On my local machine conda is configured using ArcGIS Pro, however when I run a script in a workbook I get the following error in visual studio code:

Failed to connect to remote Jupyter notebook.
Check that the Jupyter Server URI setting has a valid running server specified.
Error: Kernel Python 3 is not usable. Check the Jupyter output tab for more information.

Question is how to start a server.

When I run the Jupyter notebook app it gives me an URL, in the form:

If I copy this in visual studio, it prompts me to reload visual studio code.

However when I try to run a shell command it does not find the CLASSPATH variable, when matching the correct jar files it runs fine.

Now when I use the following grammar to test:

// Define a grammar called Hello
grammar Hello;
r  : 'hello' ID ;         // match keyword hello followed by an identifier
ID : [a-z]+ ;             // match lower-case identifiers
WS : [ \t\r\n]+ -> skip ; // skip spaces, tabs, newlines

It generates the parser and lexer. However when I run this antlr does not seem to be installed under the default environment.