Inkscape not linking for PDF export

Win10 64, using latest Inkscape 64 (1.0). I installed Inkscape after Jupyter Lab and get the following error when I try to export to PDF:

nbconvert failed: Inkscape executable not found

I would have installed Inkscape first if it was listed as a dependency. It seems like that is still not clearly mentioned in the docs!

This has been mentioned over in the Github comments, it appears to be an issue with the PATH variable not being filled for file association, but I (and hopefully somebody else in the future) would really appreciate a simple, clear step-by-step on getting the variable filled in.

I’m assuming that I begin with: “PATH” in the start menu -> environment variables -> Path -> and add Inkscape, however Google is NOT your friend when “path” is a frequent keyword for Inkscape. I’m not sure what I should be naming things (e.g “Inkscape”).

All help is appreciated!

Edit: I encountered a similar problem when installing Jupyter Lab on another machine when I accidentally failed to install MikTeX before install nbconvert (I don’t learn, apparently). For that issue simply uninstalling and then reinstalling nbconvert solved the issue. Doing this did not fix the PATH issue with Inkscape, however.

It’s a problem somewhat with how Inkscape is installed. The current way of locating the executable is to look through the PATH environment variable and if it can’t be found on the PATH then it looks in the Registry. Neither is ideal but if the installation of Inkscape does neither of these steps, it can’t be found. My contribution was to give nbconvert a way to find Inkscape in the PATH because I installed Inkscape using Scoop and I didn’t have the Registry entry, but I did have it in my PATH because all Scoop installed apps have shims which make it easy to call from the command line. I’m not really satisfied with that.

I’d recommend opening another bug and link it to bug 456. Use an “@” mention to me, and I’ll take a look at it and see if there’s something else I can contribute to improve this. My fix in October was really just to unblock me and hopefully assist others, but I can see if there’s a better approach or document why there isn’t.

Agreed with @ryanb – also thanks so much for helping with this topic. We do appreciate having community driven help on these things as there’s not many of us with free time to fix everything.

For @null (nice handle :stuck_out_tongue: ) have you tried using the alpha version of nbconvert (6.0.0a1)? The change ryanb made is in that release and might help if you’ve got 5.6.1 install instead. We’re pushing on the last changes needed to do a full release of 6.0, but knowing if there’s gaps we should try to address before that finalizes would be good to capture.

I had two errors, one regardink the executable not found -> adding the directory to the PATH variable solved this. (nbconvert failed: Inkscape executable not found)

The other error plainly stated that the conversion failed. (nbconvert failed: Inkscape svg to pdf conversion failed)
I’ve installed the a4 pre-release of nbconvert, which did not solve the problem.
But I had the jupyter server output, where the exception showed the mistreatment of spaces in the Inkscape executable path. (I’m on Windows 10.)
I reinstalled Inkscape in a path with no whitespace and the problem was solved!

Thanks for reporting, would you be willing to make that an issue on the nbconvert github? Also happy to help point people to how to contribute these changes themselves if someone wanted to take a stab at making sure the path is quoted properly.