I can not open more than one notebook in the same workspace with links any longer in JL 3

Hi all,

I am reposting my question here from GitHub issues because I am not sure if this is a bug/regression or a feature request. To me it looks more like the former…

I have a JupyterHub plus JupyterLab installation using docker images based on the docker-stacks images.
I have a bunch of notebooks loaded in the image, the same image for all users, and I have an HTML page with an index of these notebooks with links to them in JupyterLab.

With JupyterLab 1.x I can open the first notebook clicking on the index page and having a second browser tab opening with the following URL:
then I can open a second notebook in the same JL tab by clicking on a second link in the index page:
wit the result of having 2 notebooks open in the same JL page and with notebook2.ipynb selected.

Both links will open in the same browser tab by setting the same target for all links in the index page.

I upgraded my images based on the latest docker-stacks jupyter/scipy-notebook image and with JupyterLab 3.0.14 the above behavior does not work.
I read the documentation about JupyterLab URLs and I tried to change the links adding the clone query string like this
but it does not work, instead I get JupyterLab reloaded with all tabs closed.

I then tried to use workspaces using the following 2 URLs but it does not work either:

To me this is a regression.
What am I missing here?
How can I get the same behavior I had with JupyterLab 1.x using the latest version?

Thank you,

Workspaces seem temporarily broken, see here. Could that be part of the issue for why trying that approach isn’t working?

UPDATE: Maybe workspaces work via MyBinder sessions if you try on a fresh machine or in fresh browser? See discussion going forward from here. So maybe linking to notebooks not broken? There is a caveat about the current ‘Try Jupyter’ JupyterLab example not working with the work-around or solutions that have worked elsewhere to resemble a fresh launch, see the ‘Caveat’ description here, which may suggest it is JupyterLab 3 or specific versions of JupyterLab 3 that do indeed have workspace issues.

Thank you!
Yes, indeed it looks like a JupyterLab 3 bug, because I created a new Dockerfile for the image I launch and I selected JupyterLab 2.3.1 and the links work again.
This is a workaround for now, but I like the new features like command palette and the file search in JL 3.

1 Like