How to limit undo only to code edits in active cell?

Not fully sure when and what changes but in the past when being in “edit mode” in a specific code cell hitting “Ctrl+z” was just undoing the changes in this cell.

Now the behaviour seems global to edits in in other cells and other cell operations.

How can one only undo code changes in the active cell?

P.S. This is for Jupyterlab 3.1.x.

3 Likes

Not an answer, but a quick note: this is tracked in Allow to disable the document-wide history tracking · Issue #10791 · jupyterlab/jupyterlab · GitHub.

1 Like